Blackboard Classroom Latency
Incident Report for La Salle College High School
Resolved
Blackboard has notified us that the slowness issues have been resolved. We are continuing to monitor Blackboard on a regular basis. Please email support@lschs.org if you continue to experience issues.
Posted Mar 23, 2020 - 19:45 EDT
Update
Blackboard has acknowledged a latency issue and is investigating the root cause. We will continue to post information as it becomes available.
Posted Mar 23, 2020 - 14:17 EDT
Investigating
We have received reports (and are currently experiencing) slowness and latency with the Blackboard Classroom LMS. We are working to identify the issue with Blackboard and will update as soon as possible.
Posted Mar 23, 2020 - 13:27 EDT
This incident affected: Academic Technology (Blackboard Classroom LMS).