External Inbound Phone Calls
Incident Report for La Salle College High School
Resolved
Our service provider has resolve the issue with inbound calling. If you continue to experience difficulty, please email support@lschs.org.
Posted Dec 07, 2017 - 16:28 EST
Investigating
We are investigating reports of difficulties calling into La Salle. We are investigating this further with our telecommunications provider and will provide additional details as they become available.
Posted Dec 07, 2017 - 11:13 EST